North America Location Reset Issues
Incident Report for SmartThings
Resolved
We have released a platform fix that should prevent locations from getting inadvertently reset when prompted with the “Confirm your country” screen. If you are unexpectedly shown the “Confirm your country” screen, contact support@smartthings.com and force quit & re-open the mobile app to return to your existing location.
Posted 10 months ago. Oct 28, 2016 - 13:03 EDT
Update
We have identified the root cause of the Location Reset issues. Similar issues are also affecting a limited number of iOS users. We are working on a platform update and expect to release it shortly.

CAUTION - Until this issue is resolved, if you are unexpectedly prompted with “Confirm your country” screen, please force quit and re-open the mobile app to return to your existing location.
Posted 10 months ago. Oct 27, 2016 - 13:47 EDT
Identified
CAUTION - Some Android users in North America are getting prompted to re-enter their Welcome Code when opening the SmartThings app. Proceeding with this will delete your existing setup. Force quitting and re-opening the mobile should return to your existing setup. We are working to identify the root cause of the issue and will provide updates shortly.
Posted 10 months ago. Oct 27, 2016 - 12:26 EDT
This incident affected: Hub Connectivity (North America) and Mobile App Connectivity (North America).