Issue with Soft Factory Resets on 2015/2018 Model Hubs
Incident Report for SmartThings
Resolved
This issue has been resolved with the release of Hub firmware version 25.32. The soft factory reset function on up to date 2015 and 2018 model Hubs should work as expected. Please contact us via support.smartthings.com if you have any questions.
Posted 5 months ago. May 21, 2019 - 18:08 EDT
Investigating
We recently identified an issue that can break communication with secure Z-Wave devices (e.g., locks) after performing a soft factory reset on 2015 and 2018 model Hubs running firmware version 25.26 and above. This soft factory reset, also known as a firmware flash, is initiated by holding the red reset button and releasing after approximately 15 seconds when the LED is rapidly blinking yellow.

Support may have recommended this as a troubleshooting step in the past and under normal circumstances only re-downloads the latest firmware without impacting devices, but we recommend against performing soft factory resets while our teams investigate a fix.
Posted 6 months ago. Apr 11, 2019 - 20:27 EDT
This incident affected: Europe, Middle East, and Africa (SmartThings.com).