Customer Support Outage
Incident Report for SmartThings
Resolved
The issues our support center experienced receiving phone calls have been resolved. You can reach out to us by calling 1-800-SAMSUNG (1-800-726-7864) or by visiting support.smartthings.com if you have any questions.
Posted 6 months ago. Jun 19, 2018 - 20:46 EDT
Investigating
Our support center is experiencing intermittent issues receiving phone calls. We are still able to assist via email at support@smartthings.com. We are working with our service provider to address the issues and will provide updates as they are available.
Posted 6 months ago. Jun 19, 2018 - 20:02 EDT
This incident affected: SmartThings.com.