Customer Support Outage
Incident Report for SmartThings
Resolved
Our North American support center connectivity is restored. You can reach out to us at https://support.smartthings.com via phone or live chat starting tomorrow at 9 am Pacific. If you emailed us in the meantime, we will respond as soon as possible. Thank you for your patience.
Posted 7 months ago. Mar 12, 2018 - 22:24 EDT
Investigating
Our support center is currently unable to answer calls or receive live chats. For assistance via email, please reach out to us at https://support.smartthings.com.
Posted 7 months ago. Mar 12, 2018 - 17:00 EDT
This incident affected: SmartThings.com.