SmartApp and Device Control Issues
Incident Report for SmartThings
Resolved
The database change implemented yesterday caused a failure with some installed SmartApps. We identified the cause of the failure and, in the short-term, are implementing alerts and monitors to prevent future occurrences. We are also investigating longer-term architecture options to more easily regression test and mitigate issues with similar platform changes.

If you are using a community developed SmartApp, please reach out to the forums for assistance and guidance. If you are experiencing difficulty with a Marketplace SmartApp, please contact support using this form (https://support.smartthings.com/hc/en-us/requests/new?ticket_form_id=106463).
Posted Jul 26, 2016 - 17:04 UTC
Update
The reversion to the database change was effective but we continue to investigate options to restore SmartApps and Devices. We will provide additional updates tomorrow.
Posted Jul 26, 2016 - 01:54 UTC
Monitoring
A database change this morning caused limited issues with SmartApp and device state updates for some customers. We reverted the change and are monitoring the impact. If any devices or SmartApps are not currently appearing in your mobile app, please submit a ticket to support (https://support.smartthings.com/hc/en-us/requests/new?ticket_form_id=106463) with the name of the missing SmartApps or devices. We are investigating options to restore these and will follow up accordingly.
Posted Jul 25, 2016 - 17:17 UTC
Investigating
Some users are experiencing issues saving and controlling SmartApps & devices. We are investigating the issue and will provide updates accordingly.
Posted Jul 25, 2016 - 16:26 UTC
This incident affected: Americas (Mobile App) and Europe, Middle East, and Africa (Mobile App, SmartThings.com).