Smart Home Monitor Issues
Incident Report for SmartThings
Resolved
We have addressed performance issues with Smart Home Monitor and are resolving the current incident. We realize that some users are still experiencing trouble related to broader platform reliability and we are working to improve overall performance.
Posted Apr 14, 2016 - 22:05 UTC
Update
While we had hoped to launch further changes to Smart Home Monitor this week, we are delaying those releases in favor of deeper testing and other improvement measures targeted at platform reliability. We will continue to provide updates on significant changes in performance and will offer further detail as those changes are set to go live next week.
Posted Apr 08, 2016 - 22:19 UTC
Update
More changes to improve Smart Home Monitor performance are on track for release this week. We will provide updates and continue to monitor performance as those changes go live.
Posted Apr 05, 2016 - 18:24 UTC
Update
Monitoring systems indicate that performance has improved, but we are still working to resolve issues with changing alarm states through Smart Home Monitor. We are continuing to tune our database infrastructure and will look to deploy targeted measures to increase Smart Home Monitor reliability early next week.
Posted Mar 31, 2016 - 20:45 UTC
Identified
We have added more database capacity and fully migrated to a new scheduling system. Together, these have significantly improved platform performance. We are now working on additional measures to improve the stability of Smart Home Monitor, but other SmartApps appear to be executing reliably. We will provide additional updates shortly. If you have any questions, please contact support@smartthings.com
Posted Mar 28, 2016 - 20:09 UTC
Update
Additional platform improvement efforts are scheduled for release on Monday, March 28, 2016 including changes to Smart Home Monitor itself that should increase reliability. We will provide updates when those changes have been deployed as well as updates on significant changes in performance over the weekend.
Posted Mar 26, 2016 - 00:52 UTC
Update
We are on track to shift all North American users to our new scheduling system this week. This should further reduce load on our database and improve platform performance and reliability as a result. We will continue to push stability efforts into early next week and will provide updates as further information is available.
Posted Mar 23, 2016 - 19:50 UTC
Update
While we are still investigating the root cause, we are continuing efforts to improve platform performance. Over the last several days, we have expanded our data management resources, added additional server clusters to our existing infrastructure, and began enabling our improved scheduling system for customers in North America. This has resulted in reduced load and improved performance for many users. Some customers are still experiencing issues, however, and we will continue our work until the issue is resolved.
Posted Mar 21, 2016 - 22:20 UTC
Update
While overall performance has improved, some users are still experiencing issues with Smart Home Monitor, Routines, and other SmartApps. We will provide further updates as we continue to investigate and address the issue.
Posted Mar 20, 2016 - 05:07 UTC
Update
Monitoring systems indicate that Smart Home Monitor performance has improved. We are still working to identify the root cause and continuing our efforts to increase database capacity and stability. We will continue to provide updates on our progress.
Posted Mar 19, 2016 - 17:42 UTC
Update
Efforts to increase stability and Smart Home Monitor performance are still in progress, as is our investigation into the issue’s root cause. We are evaluating additional options for improving database capacity and reliability and will continue to monitor the current performance. We will provide further updates accordingly.
Posted Mar 19, 2016 - 01:03 UTC
Update
We are still investigating the issue and are pushing hard on efforts to increase capacity and performance. We will continue to provide updates as new information and developments become available.
Posted Mar 18, 2016 - 21:13 UTC
Update
We are continuing to monitor the situation and are working to both identify and resolve the issue’s root cause. We will provide further updates here as well as our community forum: https://community.smartthings.com/t/update-recent-smartthings-user-experience-platform-performance/42547
Posted Mar 18, 2016 - 16:37 UTC
Update
Efforts to increase database capacity are underway. We are monitoring the situation closely and will provide updates on our progress in identifying the issue’s root cause. We will continue to post updates here as well as on our community forum as further information is available: https://community.smartthings.com/t/update-recent-smartthings-user-experience-platform-performance/42547
Posted Mar 18, 2016 - 05:27 UTC
Update
While monitoring systems indicate performance has improved, we're actively working to identify the root cause of the issue. We are still investigating, and we will continue our efforts through the night to improve performance and increase capacity in our systems without further impacting reliability.

Further detail and discussion will continue on our community forum as well: https://community.smartthings.com/t/update-recent-smartthings-user-experience-platform-performance/42547
Posted Mar 18, 2016 - 01:05 UTC
Update
We are continuing our efforts to resolve this issue in the short-term and long-term by increasing our database capacity and improving our underlying platform architecture. Further detail and discussion is available on our community forum here: https://community.smartthings.com/t/update-recent-smartthings-user-experience-platform-performance/42547
Posted Mar 17, 2016 - 22:00 UTC
Update
The SmartThings platform is under unexpectedly high load, which is resulting in degraded access to and control of Smart Home Monitor, Routines, and other SmartApps within the SmartThings mobile app. We are authoring a more detailed update on the actions we are taking and will link to that article on our community site as soon as it is posted. Regardless, we will provide another update within 2 hours.
Posted Mar 17, 2016 - 20:39 UTC
Update
We continue to see reports of issues with Smart Home Monitor. SmartThings has taken action to improve the situation and will provide an incremental update within two hours.
Posted Mar 17, 2016 - 18:47 UTC
Investigating
Some users are experiencing issues accessing and controlling Smart Home Monitor. We are investigating the issue and will provide updates accordingly.
Posted Mar 15, 2016 - 16:13 UTC
This incident affected: Americas (Mobile App, Developer Tools).