Customer Support Outage
Incident Report for SmartThings
Resolved
The issues our support center experienced receiving phone calls have been resolved. You can reach out to us by calling 1-800-SAMSUNG (1-800-726-7864) for assistance over the phone. Our live chat and email channels are also available at https://support.smartthings.com.
Posted 13 days ago. Apr 12, 2018 - 16:54 EDT
Identified
Our support center is experiencing intermittent issues receiving phone calls. We are still able to assist via live chat on https://support.smartthings.com as well as email support via support@smartthings.com.
Posted 13 days ago. Apr 12, 2018 - 15:35 EDT
This incident affected: SmartThings.com.